7 wincag 1. Einfihrung 1

1. Einfihrung

WinCag ist ein Programm zur zeichnerischen Darstellung geometrischer Zusammenhénge
(Computer Aided Geometry) und bietet die Mdglichkeit, diese Zusammenhdange in Abhangigkeit
von einer Variablen als Bewegungsablauf vorzufihren.

Das Programm unterscheidet
- den Eingabe-Modus, einzustellen mit der Tastenkombination ctrl alt N

er dient zur Eingabe der Zeichnungen und erstellt dabei Dateien mit den Endungen
.cag und .map.

und

den Demo-Modus, einzustellen mit der Tastenkombination ctrl alt D

er dient zur Ansicht der eingegebenen Zeichnungen. Daflir muss eine Datei mit der
Endung .cfg erstellt werden, die die Reihenfolge der angezeigten Zeichnungen und
den Ablauf von Bewegungen steuert.
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2. Eingabe-Modus

Programm starten:  Auf doppelklicken.  ( Das Programm befindet sich nach

dem Aufrufen im Demo-Modus und
wird mit Ctrl Alt N in den Eingabe-
Ctrl AltN Modus geschaltet.
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2.1 Grundriss und Aufriss eines liegenden Zylinders
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2.1.1 Vorzeichnen
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Bitte beachten: Zum Nachvollziehen der folgenden Anweisungen ist es wichtig,

die Reihenfolge der Eingaben einzuhalten. Den vorgezeichneten Objekten werden
vom Programm Nummern zugewiesen, die im spéteren Verlauf weiterverwendet
werden.

Wenn Fehler unterlaufen sind und dadurch die Nummerierung nicht mehr
ubereinstimmt, sollten unbedingt die letzten Befehle riickgangig gemacht werden,
bis zu der Stelle, an der noch alles stimmt. Die Erfahrung zeigt (hier jedenfalls),
dass die langsame, griindliche VVorgehensweise meistens schneller zum Ziel fihrt!

Vorzeichnen der Koordinatenachsen: — .

Diese Eingabeauf- Nummer des erzeugten
forderung erscheint in Objektes. .
der Anzeigeleiste P1,234 L_md L 1,2 sind
Define » Point H : als Koordinatenachsen
voreingestellt.

>Select Point

beliebige Stelle anklicken, z.B. x=4, y=12 {P 5}

Esc

Die Koordinaten des Cursors

konnen in der Anzeigeleiste
unten rechts abgelesen werden.
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Make Objects » Parallel through Point

>select point Get Point:

P5 anklicken (wird in rot angezeigt)

>FndGd1: Select Point on line

untere Koordinatenachse (L1) anklicken {L 3}
(L 1 wird in rot angezeigt)

Esc - —
Mit Esc wird jeder Befehl beendet, er kann
aber auch jederzeit abgebrochen werden.

Help » Cancel last Command

Zur Demonstration wird der letzte Befehl
riickgangig gemacht, der Vorgang kann {-L3}
beliebig oft wiederholt werden.

Make Objects » Parallel through Point

>select point Get Point:

P5 anklicken
>FndGd1: Select Point on line

untere Koordinatenachse (L 1) anklicken {L 3}

Esc
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Define » Define Point Relative

>FndPol: Select given Point

P5 anklicken

>Point on Line? Ja/Nein - linke/rechte Maustaste

linke Maustaste fur "'ja*"

>FndGd1: Select Point on line

Zur verkirzten
Darstellung

zugewiesen wird. Nur
vorgezeichnete Objekte werden

werden jetzt QJmmeriert.

nur noch die

anzuklicken-
den Objekte
angegeben.

/

L 3 anklicken, z.B. bei x=10 {P 6}
Esc
File » Redraw and keep helplines
Die Zeichnung wird aktualisiert.
Beim Vorzeichnen wird die Eingabe
nicht immer sofort angezeigt
Color » Mark Points
> Get Point: Bewegliche Punkte werden
markiert, um sie spater besser
PS5, P6 wiederzufinden. Diese Markierung
ist ein Zeichenobjekt, dem keine
Esc Nummerierung vom Programm
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Beschreibung der eingegebenen Befehle ansehen:

,,Show construction :

Specials » Show construction text

Das folgende Fenster erscheint:

Construction

1 :S55cale[-0.90000000, 27.50000000, -0.50000000, 19.90000000);
DefPoS[ 0.00000000, 0.00000000): {P 1}
DefPo5[ 27.00000000, 0.00000000); {P 2}
DefPoS[ 0.00000000, 19.00000000]:

: .Eonstructlon

2:
3.
4:
5
2 1 1 efF'DS[ 27.00000000, 19.00000000); {P 4}
8
9

Definition der
Koordinatenachsen

6 : DefLin[ 1, 2); {I 1}
7 :DefLin[ 1, 3): {1 2)
§ : DefPoi[ 0, 4.01000000, 12.01000000); {P 5} L
9 : ParaPo[ 5, 1); {I 3} 1

10: DefPoR[ 3, 5, 5.95000000, 0.00000000); {P 6} Elgene
11 : MarkPo[ 5, 9, 2, 3. 1); Eingabe
12 : MarkPo[ 6, 9, 2, 3, 1)

q 2
ECNET 1 NS

Die Die Alle Nur Nur Nur Nur Nur
vorheri- | néchsten | Arten von | Punkte | Linien | Kreise | Sonstige Zeichnungs-
gen 100 | 100 Eintrégen (Ellipsen, ) | Eintrage
Eintrége | Eintrége

Die Bedeutung der Schreibweise ist im Anhang bei dem jeweiligen Befehl erléutert.
Diese Datei kann nicht bearbeitet, sondern nur angesehen werden!

Schalter 3 bis5 und 8 anklicken,
Fenster schliel3en (,,X“ oben rechts in der Ecke)

,»cag-Datei*:
Vom Programm wird eine ,,cggq-Datei“ mit der gleichen Darstellungsweise der Eingaben

angelegt:
Ell=

Datei Bearbeiterr Format 2

sScalef -0.90000000, 27.90000000, -0.090000000, 19.900000007; ;l
pefPos( 0. 00000000, 0.000000000; fP 1%

pefPost 27.00000000, 0.000000000; {FP 27}

pefPos(  0.00000000, 19.000000000;: fP 31

pefPos( 27.00000000, 19.00000000); fP 47

pefLin{ 1, 2J; {1 1}

pefLing 1 30 011 2%

pefPoi¢ O, 4.01000000, 12.01000000%; {P 5}
Parapo( 5, 1); {1 3}

pefrPor( 2, &, 5.98000000, 0.00000000); {P &}
Markrof 5, 9, 2, 3, 10;

markpof &, 9, 2, 3, 1J;

4] H 4

Diese Datei kann mit einem Textprogramm bearbeitet werden!
Im spateren Verlauf der Beschreibungen ist es notwendig mit dieser Datei zu arbeiten,
zur Vorgehensweise siehe Kapitel 4.1.

Nutzungsmdglichkeiten der cgg-Datei: - Eingaben auch in Textform,
- Anderungen der vorhandenen Eingaben.
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Modify » Points

>FndPol: Select given Point

P5 auswahlen und mit linker Maustaste halten

>Move mouse

P5 auf x=3 und y=10 ziehen

>FndPol: Select given Point

P6 auswahlen und mit linker Maustaste halten

>Move mouse

Esc

P6 auf x=11

Make Objects » Parallel through Point

>select point Get Point:

P5

>FndGd1: Select Point on line

Esc

linke Koordinatenachse (L 2)

{L 4}

Define » Define Point Relative

>FndPol: Select given Point

P5

>Point on Line? Ja/Nein - linke/rechte Maustaste

linke Maustaste fur "'ja"

>FndGd1: Select Point on line

L4, bei y=17

{P7}

>FndPol: Select given Point

P5

>Point on Line? Ja/Nein - linke/rechte Maustaste

linke Maustaste flr "'ja"

/Die Linie L4 bekommt mit\

>FndGd1: Select Point on line

P7 einen Endpunkt und ist
bisher nur in diesem

L 4, z.B. bei y=11

Abschnitt definiert, d.h.

sie kann nicht unterhalb
Esc von P5 angeklickt Werden./

{P 8}
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File » Redraw and keep helplines

Modify » Points

>FndPol: Select given Point

P8 auswahlen und mit linker Maustaste halten

>Move mouse

P8 auf y=1 ziehen

Esc

Color » Mark Points

> Get Point:

P7, P8

Esc
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Color » Join Points Ve

Die vorgezeichneten Hilfslinien

> Get Point: der Koordinatenachsen werden
jetzt schwarz gezeichnet, um sie

P5, P6, hervorzuheben.

PS5, P7, N~ 4

P5, P8

Esc

Vorzeichnen des Aufrisses:
Auflager R — =

Define » Define Point Relative

>FndPol: Select given Point
P7

P5

>Point on Line? Ja/Nein - linke/rechte Maustaste

linke Maustaste fur "'ja"

>FndGd1: Select Point on line

ps L pe L 3, bei x=10 {P 9%}

Esc
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Color » Mark Points

> Get Point:
P7

P9

Esc

Make Objects » Parallel through Point

>select point Get Point:

P9

>FndGd1: Select Point on line

linke Koordinatenachse (L 2)

Esc

{L 5}

Define » Define Point Relative

>FndPol: Select given Point

P9

>Point on Line? Ja/Nein - linke/rechte Maustaste

linke Maustaste flr "'ja"

>FndGd1: Select Point on line

L 5, bei y=12,5

Esc

{P 10}
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File » Redraw and keep helplines
Color » Mark Points
> Get Point:
P10
Esc
P5 P3 PE
Make Objects » Orthogonal through Point
>select point Get Point:
P7
P10
>FndGd1: Select Point on line
L4 {P11}{L 6}
P10 Esc

P& P PE
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Vorzeichnen des Aufrisses:

Zylinder | e=s—

i

Il
by
K

Make Objects » Midpoint

PT

P10

>1. point Get Point:

P5

>2. point Get Point:

P9

Esc

{P12}

Make Objects » Parallel through Point

>select point Get Point:

P12

>FndGd1: Select Point on line

L2

Esc

{L 7}
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Intersections » Line » Line
>FndGd1: Select Point on line
L6
>FndGd1: Select Point on line
L7 {P 13}
Esc

File » Redraw and keep helplines

Define » Define Point Relative
>FndPol: Select given Point
P13
>Point on Line? Ja/Nein - linke/rechte Maustaste
“ja
>FndGd1: Select Point on line
L 6, beix=8,5 {P 14}

Esc
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Color » Mark Points
> Get Point:
P14
Esc

Define » Circle
>centre Get Point:
P13
>GtDstP1: Get Point:
P14
>GtDstP2: Get Point:
P13 {C1}
Esc
Intersections » Line » Circle

>FndGd1: Select Point on line
L6
>FndCil: Enter Circlepoint
C1
>Select Main-Point
linker Punkt {P 15}
>FndGd1: Select Point on line
L7
>FndCil: Enter Circlepoint
C1
>Select Main-Point
unterer Punkt {P 16}

esc
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Color » Mark Points

/
o P15 ist nicht beweglich
> Get Point: und wird hier nur markiert,
P15 um den nachfolgenden
Bewegungsablauf besser
erkennen zu kénnen
Esc \ J

Modify » Points

>FndPol: Select given Point -
9 Bei dieser Bewegung

P14 kann man erkennen,
dass P15 auf der
>Move mouse linken Seite des

: - Kreises bleibt, weil
P14 nach links Uber den die Lage nicht

Kreismittelpunkt schieben eindeutig definiert ist.
und wieder zuriick

Esc

Modify » link intersection

Mit dem Befehl wird die Lage des
Schnittpunktes in Relation zu einem
vorher definierten Punkt fixiert.

Um Uberraschungen zu vermeiden,
sollte die Lage jedes Schnittpunktes
mit einem Kreis oder einer Ellipse
fixiert werden.

>nearest/farest point: FndPol: Select given Point

P15

>nearest/farest point: link point to FndPol: Select given Point

P14

>nearest/farest point: nearest point? Ja/Nein - linke/rechte Maustaste

rechte Maustaste fir “nein”

>nearest/farest point: FndPol: Select given Point

P16

>nearest/farest point: link point to FndPol: Select given Point

P12

>nearest/farest point: nearest point? Ja/Nein - linke/rechte Maustaste

linke Maustaste fur “ja”

Esc
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Modify » Points

>FndPol: Select given Point

P14

>Move mouse

e
Jetzt bleibt P15 auf der
gegeniberliegenden Seite

P14 nach links tber den
Kreismittelpunkt schieben
und wieder zurick auf x=8,5

Esc

PS

von P14.

Modify » modify more Mark Points

MarkStyle Eingabe — 5‘

>Select drawn Point

P15

Esc

'ﬁ"arli&i:};lz.:

_E] IR

Markyp | Fame(0.16

Dicke (1..9) ' Layer

|3

| |k
Loschen

Esc
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Vorzeichnen des Grundrisses: g

i
b sy et Do i i o Py bt

Define » Define Point Relative

P14 P10
+ .

>FndPol: Select given Point

P5

>Point on Line? Ja/Nein - linke/rechte Maustaste

ja

>FndGd1: Select Point on line

L 4, beiy=2 {P17}

Esc

Color » Mark Points

> Get Point:

P17

Esc
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Make Objects » Orthogonal through Point

Zur Erinnerung: Moglicherweise
werden die Linien erst nach der

>select point Get Point: Einga}be von “Redraw and keep
helplines* eingeblendet.
P17 b -
>FndGd1: Select Point on line
L5 {P18HL 8}
>select point Get Point:
P14
>FndGd1: Select Point on line
L8 {P19}HL 9}
>select point Get Point:
P15
>FndGd1: Select Point on line
L8 {P20}{L 10}
Esc
File » Redraw and keep helplines
Intersections » General (by point)
>|S-Point:
L 3/L 10 (1) (in die Ndhe des gewiinschten {P 21}
Schnittpunktes klicken)
>|S-Point:
Vereinfachte Eingabe von P22
L3/ L9 ) Schnittpunkten, wenn nicht mehr als { }
zwei Objekte an der Stelle liegen. Sonst
Esc werden die gefundenen Objekte der
Reihe nach abgefragt und mussen
bestatigt werden.
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Make Obijects » Devide

>1. point Get Point:

P21

>2. point Get Point:

P20 {P 23}

| Teilungsverhiiltnis 2 ( Eingabel )

rl

| rl

r2 = 4.0 eintragen o

o] ] ok

Eingabe 2
Esc ~——

Color » Mark Points

> Get Point:

P23

Esc

Make Objects » Do Distance

>FndGd1: Select Point on line

L 10

>from P: Get Point:

P20

>distl: Get Point:

P21

>dist2: Get Point:

P23

>select wanted point

oberen Punkt wahlen {P 24}

Esc
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Modify » link DoDist

Wie bei ,link intersection® sollte
auch bei ,,do distance” die Lage des
Punktes relativ zu einem vorherigen
Punkt fixiert werden. Damit wird
verhindert, dass er ungewollt auf die
andere Seite springt.

>nearest/farest point: FndPol: Select given Point

P24

>nearest/farest point: link point to FndPol: Select given Point

P23

>nearest/farest point: nearest point? Ja/Nein - linke/rechte Maustaste

uj a”

Esc

Modify » Points

>FndPol: Select given Point

P23

>Move mouse

P23 auf y=7,5

Esc

Make Objects » Orthogonal through Point

>select point Get Point:

P23

>FndGd1: Select Point on line

L9

{P25}L 11}

>select point Get Point:

P24

>FndGd1: Select Point on line

L9

Esc

{P26}{L 12}
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Intersections » Line » Line

>FndGd1:

Select Point on line

L7

>FndGd1:

Select Point on line

L11

{P 27}

>FndGd1:

Select Point on line

L7

>FndGd1:

Select Point on line

L 12

{P 28}

>FndGd1:

Select Point on line

L7

>FndGd1:

Select Point on line

L8

esc

{P 29}

File » Redraw and keep helplines
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Speichern:
File » Save as
Il
6er Pfad entspricht dem . Fomost =
" Filename:
2?cshlireolgr2rr1rgjr:rse¥v§r?t:r Dubston: &-Wwacagsui] Filename: [211self | | Filename :
! _— ; D Directory: c:\wincaghtutorial\demos | 211self
,.Directories” gewahlt i Bioviins e 7
wird. Im Auswahifeld | e — - eintragen,
darunter bedeuten: el [show]
[..] einen Pfad zurtick, fel V.DE' L] “ b OK
[abc] mogliche Pfade. — L. {g} [-d-] o
\ 7 {jil‘-]j x : {_.;?_-']J
ol Abbruch [-a-] :
- 7
) {__.m]__] I {:L—l]_] xnhbruch _
,,demos* auswahlen, :
OK

Programm beenden:

File » Exit

Oder: X (oben recht auf dem Bildschirm)
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2.1.2 Zeichnen

Programm starten:  Auf doppelklicken.

Ctrl Alt N

File » Load
X
Filename: |2128lall.cag ‘ :
Directony: ¢-\wincagMutorial\demos.
LA I ] S D_"gctnﬁg& — - ..
il Feow V=] »212start.cag* markieren,
: g wl ;
|221stait cag l-a] i
e |222stait.cag -c-
|4#1start.cag OK

|42start.cag

e e P e
oo ol

3

Beim Zeichnen der sichtbar bleibenden Objekte ist die Einhaltung der Reihenfolge fir das
Nachvollziehen der nachfolgenden Beschreibungen unbedeutend. Den Zeichenobjekten wird keine
Nummerierung zugeteilt.

Specials » select active layers

~

Bisher wurde die Zeichnung
x| als Vorlage konstruiert.
Layerbraatin ] Far _die Darstellung vv_ird jetzt
_ farbig auf Layer gezeichnet.
Layerl Ll Es stehen 16 Layer zur
Lavels =l Verfligung. Sie kénnen fr die
Layer3. Si spétere Demo-Darstellung
Layerd = separat ein- und ausgeblendet
Lavehs si werden.
Layer 6 [ K /
Layer 7 =
Layer 8 Sl
Layer 9 =
Layer 10 i
Layer 11 =
S | Vorlage ausschalten,
ayer 12 = R
Layer 13 - | Layer 1 einschalten,
Layer 14 [
Layer 15 [
Layer 16 M OK
Yorlage [T
“ IS Ix;xbhruch
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Zeichnen der Koordinatenachsen:

b sy et Tt i Pt Py bt

i

Color » Join Points

> Get Point:

P5, P6,
P5, P7,
P5, P8

Esc

Modify » modify more Join Points

>Select Point on drawn part

(Eine Tabells

die 3 gezeichneten Linien anklicken

Esc

eintragen:
Linientyp:
Farbe:
Strichstérke:

OK

Esc

5
9
2

DrawStyle Eingabe ] x|
I ﬁrawSl:y_lg,' I
Linienyp [ [ Farbe [0.16)
L 9
_| Strichlsinge ‘ _| Strichstirke [l].di I
EEETT d -
| Anzahl Teilstiche | | Layer
2 1

[ (3] [ree]

'Lﬂ'ﬁs:hznl

mit den
mdglichen
Zeichenstil-
Eingaben
steht im
Anhang.
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Zeichnen des Aufrisses:

ainial

Color » set draw-style

Dieses Fenster dient zur
Voreinstellung von Linien-
typen fur zukinftige
Zeichnungsobjekte.

Strichstarke: 2
OK

DrawStyle Eingabe ] x|
I ﬁraws:tyle, :
Cinientyp . [ Farbe (016)
L]
_| Strichlinge . o _| Strichstiirke [l]vd’]/
0.2000000 2 '
_| Anzahl Teilstriche | _ Layer
@ P |

|d ok I ‘x\kbhmohl. .“E!'unkle--]

Lfisach:nl

Color » Join Points

> Get Point:

Die vorgezeichneten Linien nachzeichnen:

P11/P15,
P14/P10,
P10/P9

Esc

[Reihenfolge unerheblich. ]

Color » Draw Circle

> FndCil: Enter Circlepoint

C1

> Draw whole Circle? Ja/Nein - linke/rechte Maustaste

“Ja”

Ll

Esc
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Zeichnen des Grundrisses:

[ N ainial

e e e e

Color » Join Points

> Get Point:

Die vorgezeichneten Linien nachzeichnen:
P17/P18,

P18/P9,

P21/P20,

P22/P19,

P23/P25,

P24/P26

Esc

Hilfslinien ausblenden und speichern:

| File » Redraw and remove helplines
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File » Save as

“212start.cag” in ,,212self.cag* andern,

OK

Bewegliche Punkte verschieben:

Specials » Set Last

/Die Hilfslinien werden alle
wieder eingeblendet, damit die
Punkte wieder angezeigt und
ausgewahlt werden konnen.

In den weilen Feldern ist die Anzahl der
ausgeblendeten Objekte angegeben, d.h.
hier kann auch eine beliebige Anzahl
der zuerst eingegebenen Objekte
ausgeblendet werden.

alle Werte auf 0 setzen, d.h. keine Hilfslinie
ausblenden
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Specials » select active layers

Die Vorlage wird zusétzlich
eingeblendet, weil dort die
Laver beweglichen Punkte markiert

sind.

PT7

Layervorgabe

Layer 1
Layer2
Layer3

P14 P10
Layer 4

Layer5
Layer b

Ps PSPt Layer 7

Layer 8
Layer 9

Layer 10
Layer 11
Layer 12

P23

Vorlage einschalten,

Layer 13

Layer 14

OK

Layer 15
Layer 16

e 1§ i i | i i e i

P17 Vorlage

L [

Modify » Points

Die nicht markierten Punkte
kdnnen nicht verschoben
P5 werden. (Anklicken wird
ignoriert oder flihrt zu einer
>Move mouse Meldung, die mit der linken
Maustaste bestatigt werden

\soll.)

>FndPol: Select given Point

P5 beliebig verschieben

>FndPol: Select given Point

P6

>Move mouse

P6 beliebig verschieben

... weiter mit allen markierten Punkten

Esc

Nicht speichern!




30 2.1 Grundriss und Aufriss eines liegenden Zylinders 7 wincag

Prasentation:

Die Prasentation der Zeichnung erfolgt im demo-Modus (s. Kap. 3) und kann hier schon angesehen
werden.

Dabei werden alle Bewegungsmaglichkeiten gezeigt.

Starten des demo-Modus:

Ctrl alt D
Demos » SHOW » 2.1 Grundriss und Aufriss
Die Bedienungsmaglichkeiten sind in der unteren Anzeigeleiste aufgelistet.

Die Ablaufgeschwindigkeit jeder Bewegung kann mit den +/- Tasten verdndert werden, ein
»GlobalFactor” wird dafur angezeigt.

Programm beenden:

Damit jedes Kapitel separat bearbeitet werden kann, wird jeweils am Anfang das Programm gestartet
und am Ende das Programm beendet.

File » Exit

Oder: X
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